MapInfo Pro

 View Only
  • 1.  Extensibility Reference Guide not working

    Posted 30 days ago
    Hello.

    I'm wondering if anyone is having this issue, where one clicks the Extensibility Reference option on the Python quick Start menu and an error message pops up. Installation problem or bug? Running on MapInfo Pro 2021 build 197


    ------------------------------
    Maria Sousa
    WOOLWORTHS GROUP LTD
    Bella Vista NSW
    ------------------------------


  • 2.  RE: Extensibility Reference Guide not working

    Employee
    Posted 30 days ago
    Hi Maria
    Do you get the same error if you try to launch the help system from the MapInfo Pro installation folder?

    Try double-clicking on the file ExtensibilityReferenceHelp.exe in the Documentation subfolder

    ------------------------------
    Peter Horsbøll Møller
    Principal Presales Consultant | Distinguished Engineer
    Precisely | Trust in Data
    ------------------------------



  • 3.  RE: Extensibility Reference Guide not working

    Posted 30 days ago
    Hi Peter.

    Yes I tried that and same result.

    ------------------------------
    Maria Sousa
    WOOLWORTHS GROUP LTD
    Bella Vista NSW
    ------------------------------



  • 4.  RE: Extensibility Reference Guide not working

    Employee
    Posted 29 days ago
    Can you check if this helps:
    https://customer.precisely.com/s/article/How-to-resolve-missing-Help-Menu-Documentation-when-opening-help-file-in-MapInfo-Pro-64-bit

    This refers to some issues with the cache files that can be fixed by removing the cache file which then will be recreated afterward.

    Try renaming the ExtensibilityReference folder.
    A new should get created when you run the help file


    ------------------------------
    Peter Horsbøll Møller
    Principal Presales Consultant | Distinguished Engineer
    Precisely | Trust in Data
    ------------------------------



  • 5.  RE: Extensibility Reference Guide not working

    Posted 27 days ago
    Hi Peter.

    I don't have the Extensibility folder on my end, maybe it's an installation problem (same for mapbasic). I do have them for the previous version, but don't want to delete anything just in case.



    ------------------------------
    Maria Sousa
    WOOLWORTHS GROUP LTD
    Bella Vista NSW
    ------------------------------



  • 6.  RE: Extensibility Reference Guide not working

    Employee
    Posted 27 days ago
    I'm getting to the end of my knowledge here :-)
    Two more suggestions and if they don't help you, you'll have to reach out to my colleagues at tech support (support@precisely.com)

    1. Try right-clicking the file ExtensibilityReferenceHelp.exe and then select Run As Administrator to launch it.

    2. Try doing the same to start MapInfo Pro by right-clicking the MapInfo Pro shortcut.

    ------------------------------
    Peter Horsbøll Møller
    Principal Presales Consultant | Distinguished Engineer
    Precisely | Trust in Data
    ------------------------------



  • 7.  RE: Extensibility Reference Guide not working

    Posted 27 days ago
    Hi Peter.

    Thanks for the help, unfortunately I don't have admin rights (the joys of working for a big company...)

    I'll contact tech support, it might jsut be that I to reinstall the program.

    Cheers
    Maria

    ------------------------------
    Maria Sousa
    WOOLWORTHS GROUP LTD
    Bella Vista NSW
    ------------------------------



  • 8.  RE: Extensibility Reference Guide not working

    Employee
    Posted 27 days ago
    Yeah, I saw some reference to repairing the installation with elevated rights that might solve a similar problem.

    Please keep us posted here in the community about your findings and the solution.

    Thanks

    ------------------------------
    Peter Horsbøll Møller
    Principal Presales Consultant | Distinguished Engineer
    Precisely | Trust in Data
    ------------------------------



  • 9.  RE: Extensibility Reference Guide not working
    Best Answer

    Employee
    Posted 13 days ago
    Just wanted to share that reinstalling MapInfo Pro with full administrator privileges had resolved this issue since Maria had raised a support case.

    The solution is to ensure that MapInfo Pro is installed with full admin privileges and on top of that, making sure the installer was run by right-clicking on the setup.exe and choosing the option to 'Run as Admin'.

    Hopefully this helps any others who may also happen to experience this and any other similar help menu issues in MapInfo Pro.




    ------------------------------
    Dave Kuo
    Principal Support Engineer
    Precisely | Trust in Data
    ------------------------------