View Only
  • 1.  ABAVN script error: "LEAVE TO TRANSACTION" is not allowed in batch input

    Posted 09-13-2023 15:06

    Hi all,

    I have created an upload script for ABAVN transaction (Studio version 12.1, SAP S/4 environment, WinshuttleFM 20.2). The users needs to run this script to scrap about 900 assets. When I run the script for my testing, it works fine but Run Log column for all records gets filled with "LEAVE TO TRANSACTION"  is not allowed in batch instead of the actual SAP message saying 'Asset transaction was posted with document No. XXXX XXXXX in acctg princ. GAAP'. This is happening for all records. I have tried all possible OK codes while completing the transaction (Continue button, New Entry, Cancel) but nothing appears to be working. I am hoping I'm missing something simple. I have attached the script.

    Thank you.

    Moazzam Mubarak
    De Beers Consolidated Mines

  • 2.  RE: ABAVN script error: "LEAVE TO TRANSACTION" is not allowed in batch input

    Posted 09-14-2023 20:18
    Edited by Sigrid Kok 09-14-2023 20:19

    Hi Moazzam

    Hard to tell from my side.  My script doesn't end with the subscreen that you have in yours.

    Attaching mine just as an example - as all systems can be setup a bit differently, and mine is a demo system.

    Mine has save - then exit - then a pop-up to end

    Your script has the subscreen at the end, and I'm not sure what that is.

    Can you run a line in debug mode to see where it is failing, i.e. where you're getting the error?  That will be the best way to determine what is going on.

    Also, please enable EXTENDED LOG from the EXPERT MODE tab.  I found in another post that I got that message on another asset transaction, but the extended logs showed the actual posting was successful.   You can see that community post here:

    Best Regards,


    Sigrid Kok
    Precisely Software Inc.


    ABAVN_AssetRetirement.Txr   415 KB 1 version
    ABAVN_AssetRetirement.xlsx   122 KB 1 version