Spectrum Spatial (SSA/LIM)

 View Only
  • 1.  2020.1 - Service Error Ok - SSA Client Error / Not responding

    Posted 12-14-2021 19:22
    Edited by Jason Hemingway 12-14-2021 19:29
      |   view attached
    I am having an issue with high volume enquirers (Customer service & Planning) getting the attached error popping up on the screen, it reoccurs if they try again and if they refresh the page it goes to a login screen (internally we are all guests so no login required).

    It feels like the client is not getting a response when an enquiry is made so I increased the remote component pool to 16 (was 4) and memory to 4GB (was 2) but we are still getting the error popping up, and of course it is a really helpful error message "service error ok".

    Anyone else seen this got a solution?

    ------------------------------
    JasonHemingway
    Cassowary Coast Regional Council
    ------------------------------


  • 2.  RE: 2020.1 - Service Error Ok - SSA Client Error / Not responding

    Posted 12-17-2021 00:40
    Hi Jason,

    The best way to get more info about these errors is to check the Network tab in the browser tools, you will need to press F12 and then switch to the Network tab before loading the page.

    What you are looking for are requests that have a status that isn't 200, if you then select this row you should see a Header and Preview/Response tabs, the Header will show the Request URL which can give you a clue as to what SSA was trying to do and the Preview/Response will give you an error if the request didn't totally fail.

    in this example of a successful request you can see that the Request URL is calling the MappingService

    and then you can see the response on the Preview tab

    If you don't get a response then I would suggest checking the Spectrum logs and then the Connect logs.

    ------------------------------
    Duri Bradshaw
    Spatial IT Consultant
    Insight GIS
    ------------------------------



  • 3.  RE: 2020.1 - Service Error Ok - SSA Client Error / Not responding
    Best Answer

    Posted 02-03-2022 19:49
      |   view attached
    Thanks @William Dean from Cairns City for the advice that the Spectrum Spatial module client timeout settings may be taking precedence over the SSA module settings. 
    • Spectrum Spatial timeout was set at 1800s (30mins) and SSA at 2hrs
    • Modified C:\Program Files\Precisely\Spectrum\server\conf\spectrum-container.properties- spectrum.security.authentication.session.timeout=11000 (3hrs)

    This seems to have done the trick, however my main complainer, I mean engaged user has been on leave for 8 weeks but others are no longer having the issue.

    ------------------------------
    Jason Hemingway
    Coordinator Spatial & Asset Services
    Information Services
    Cassowary Coast Regional Council
    Australia
    ------------------------------