MapInfo Pro

 View Only
  • 1.  V19.3 Build 43 MS Access Issue

    Posted 04-26-2021 15:48

    Hi All

    Feel like I've had this problem before in the past.
    Have an issue MIPro keeps crashing out when connecting to access accdb files.

    Running v19.3 Build 43
    Office ProPlus 2016 64 bit

    Looking in the control panel Access db engine 2010 and 2016 are also installed.

    The install process was Office then Mapinfo.
    I think I upgraded from an earlier release and it did work at some point.

    Ive downloaded build 45 should I just try an install and replace 43 first or remove the access engine files?

    Any advice appreciated.
    Martin



    ------------------------------
    Martin Dowler
    CHESHIRE & WIRRAL PARTNERSHIP NHS TRUST
    ------------------------------



  • 2.  RE: V19.3 Build 43 MS Access Issue

    Posted 04-27-2021 09:55
    Hi Martin
    Just install the Build 45 and it will replace the necessary files.
    Cheers

    ------------------------------
    John Ievers
    CDR Group
    Hope Valley, United Kingdom
    ------------------------------



  • 3.  RE: V19.3 Build 43 MS Access Issue

    Posted 04-27-2021 10:07

    I downloaded it. Will it uninstall the current version and carry over the licence etc or do I need to transfer licence and uninstall it first? I did start its installation last night but cancelled as it didn't seem to detect the current program.



    ------------------------------
    Martin Dowler
    CHESHIRE & WIRRAL PARTNERSHIP NHS TRUST
    ------------------------------



  • 4.  RE: V19.3 Build 43 MS Access Issue

    Posted 04-27-2021 10:10
    It should be picking up your existing setup - no need to uninstall or return any licences.

    ------------------------------
    John Ievers
    CDR Group
    Hope Valley, United Kingdom
    ------------------------------



  • 5.  RE: V19.3 Build 43 MS Access Issue

    Posted 04-27-2021 11:30

    I downloaded it through the store.

    Its only offering Modify/Repair/Remove in setup. 

    The main installer wont run so I'm running it from C:\Users\admin\Downloads\MapInfo_Pro_v2019.3\Install\MI_PRO\DISK1\setup.exe.

    No policies/AV issues stopping autostart.exe, just doesnt respond on the install option.

    Should I select Remove?



    ------------------------------
    Martin Dowler
    CHESHIRE & WIRRAL PARTNERSHIP NHS TRUST
    ------------------------------



  • 6.  RE: V19.3 Build 43 MS Access Issue

    Posted 04-27-2021 13:07
    Martin
    I'm not convinced that you have Build 45 there - sounds like it is still Build 43.
    Download from here:
    https://support.precisely.com/product-downloads/item/mapinfo-pro-v2019-3-evaluation-version/
    Select the setup.exe in Explorer and make sure you "Run As Administrator" from the right-click menu.

    ------------------------------
    John Ievers
    CDR Group
    Hope Valley, United Kingdom
    ------------------------------



  • 7.  RE: V19.3 Build 43 MS Access Issue

    Posted 04-28-2021 03:29

    Did the upgrade, went fine. 

    Same problem. Thinking its MS Office. Ive tried to connect to an .mdb and .accdb.
    I know it worked when installed.
    Windows 10 is up to date and all 2016 updates are installed.

    Think I will uninstall the 2016 Access engine and see if that does it, then I may have to do a complete uninstall of office.



    ------------------------------
    Martin Dowler
    CHESHIRE & WIRRAL PARTNERSHIP NHS TRUST
    ------------------------------



  • 8.  RE: V19.3 Build 43 MS Access Issue

    Posted 04-29-2021 08:22

    Just as a follow up in case others have this issue:

    I uninstalled Access db engine 2010 and 2016, checked Office 2016 still happy.
    Uninstalled MIPro and installed v19.3 (45).
    All working.
    Thanks John.



    ------------------------------
    Martin Dowler
    CHESHIRE & WIRRAL PARTNERSHIP NHS TRUST
    ------------------------------



  • 9.  RE: V19.3 Build 43 MS Access Issue

    Posted 05-11-2021 05:26
    Hi,

    We use Datamine (MIP/MID) and under the Datamine folder (under the windows icon, left click) there is an Access Database Fix.

    e.g. a couple week ago, 2 people in the office couldn't open anything Excel or Access - crashing MIP time after time.

    In my last update to Ver 19.3, 2021, the update corrupted my MS Access DB engine.

    I also noticed that MapInfo tries to update the 2010 ver of MS Access engine (deleting it), and is no doing this stuffs up ArcMap (32-bit). So you have to go back an re-install the 32-bit ver.

    Cheers, Mike

    ------------------------------
    Mike Woodbury
    Knowledge Community Shared Account
    ------------------------------