MapInfo Pro

Expand all | Collapse all

Untitled *.wor

  • 1.  Untitled *.wor

    Posted 06-02-2021 23:04
    Hi,

    Has anyone had any issues with their workspace name/label not shown up? When you open a workspace from the day before (with a name and path), it comes up as unknown (my end) at the top of MIP? Very odd.......

    It happens ~75% of the time to me, when I open existing workspaces

    I have been unable to resolve this issue with support

    The issues arises: If you forget to save the workspace straight aware (name it and call it the same name as the one you just opened) the autosave function doesn't work

    If MIP hangs or other, you end up loosing your work that took place as above 'auto save' is not active.

    Any help / pointers appreciated.

    Cheers



    ------------------------------
    Mike Woodbury
    Knowledge Community Shared Account
    ------------------------------


  • 2.  RE: Untitled *.wor

    Posted 06-11-2021 08:22
    Hi Mike
    I can only confirm that it does seem to be intermittent.
    I can't fathom why it does or doesn't show the workspace name.

    ------------------------------
    John Ievers
    CDR Group
    Hope Valley, United Kingdom
    ------------------------------



  • 3.  RE: Untitled *.wor

    Posted 06-11-2021 08:31
    Hi John,

    Appreciated. 

    I have been unable to work out why it happens as well. Support state they cannot replicate this. 

    As well, just place the latest version on, and I have to select the projection all the time, although I have set the discover favourite up as default.

    It will just not pick this up. Not sure why? It's under the apply grid to the mapper window. In long and lat

    Have you ever reached a limit with MIP?

    Processed 36 million points the other day and MIP could not spatially process them. Crashed time after time. 

    Did the exercise in ArcGis pro with 40 million points. Then saved the shapefile and opened in MIP.

    Cheers 

    Sent from Mike W iPhone





  • 4.  RE: Untitled *.wor

    Posted 06-11-2021 08:44
    Hi Mike
    UK Support have replicated the issue and passed up the chain.
    I don't know about the Projection issue - never had that come up. Is it a Discovery issue?
    I've managed to build a grid from 35,649,000,000 points. Resulting in a 26.5GB MRR file.
    I had to do it in stages. The limitation is more of a windows file handling issue. I kept it below 1,000 files at a time.

    ------------------------------
    John Ievers
    CDR Group
    Hope Valley, United Kingdom
    ------------------------------



  • 5.  RE: Untitled *.wor

    Posted 06-11-2021 10:24
    Hi John, 

    Not sure? I think it's a limitation in MIP, but not sure? Arcgis managed it running the process on a windows OS on a high end pc.

    The computer we use for the larger files has 1.5 Tb of ram and is very capable computer compared to most units around these days.

    Don't think there are many users working with datasets of this size in MIP?

    We are going to be looking at even larger datasets v. soon.

    Was hoping to understand if there is a limit in size. 

    Rgs 

    Sent from Mike W iPhone





  • 6.  RE: Untitled *.wor

    Posted 06-11-2021 10:52
    Hi Mike
    Are you using the old method in MapInfo Pro?
    Or are you using the new MRR file format in MapInfo Pro Advanced?
    Or perhaps you are using the old MapInfo tab format that has a 2 GB limit.
    The new Extended Table doesn't have a limit - in the Systems Settings Preferences...


    ------------------------------
    John Ievers
    CDR Group
    Hope Valley, United Kingdom
    ------------------------------



  • 7.  RE: Untitled *.wor

    Posted 06-11-2021 10:56
    Hi John,

    Yes, we use the extended tab format. 

    Cheers 

    Sent from Mike W iPhone





  • 8.  RE: Untitled *.wor

    Posted 06-14-2021 04:24
    Mike

    Can you be a bit more specific? "spatial processing" isn't quite vague and can mean a lot of things. What exactly are you doing? What's the goal of the process?

    ------------------------------
    Peter Horsbøll Møller
    Principal Presales Consultant | Distinguished Engineer
    Precisely | Trust in Data
    ------------------------------



  • 9.  RE: Untitled *.wor

    Posted 06-14-2021 04:30

    Hi Peter,

     

    Spatial | Create Points (MIP). Stops at 36million points and closes MIP down.

     

    Cheers, Mike

     






  • 10.  RE: Untitled *.wor

    Posted 06-14-2021 04:45
    What format does the data originate in, and did you save it into/as a NativeX table before creating points? Maybe you checked the option "Create Copy in MapInfo format for read/write" in the Open dialog?


    That only works for certain formats, however. Formats like TXT, CSV, and XSLX files.

    I checked a dataset I have done this on, but it was "only" 28M points.

    ------------------------------
    Peter Horsbøll Møller
    Principal Presales Consultant | Distinguished Engineer
    Precisely | Trust in Data
    ------------------------------



  • 11.  RE: Untitled *.wor

    Posted 06-14-2021 06:21

    Hi Peter,

     

    It's in csv format

     

    Yes, all the normal steps are followed, like any import (incl. using extended tab format, otherwise it would not get pas 2gb)

     

    It's not a complicated work flow (which I'm sure your aware) 2-3 steps and it's executed

     

    The file contains ~40,100,000 points

     

    Gets to 36,000,000 points on our large pc (with 55 cores and 1.5 tb of ram) and MIP crashes and closes down. We tried repeated times and the same end-result

     

    Cheers

     






  • 12.  RE: Untitled *.wor

    Posted 06-14-2021 13:43
    I have tried to import a MIF with 100 million random points and somewhere between 40 and 50 million it really slowed down. Now it crawls along at almost 53 million records after 3 hours of processing. No progress it seems, CPU is at 2% and a lot of disk-activity.

    The issue here is the building of the spatial index in TAB files. It is really smart (at the low-level), but costly to create from scratch - especially with lots of random data.

    The SHP file is much simpler and it's spatial index too.

    ------------------------------
    Uffe Kousgaard
    ROUTEWARE
    Roskilde
    ------------------------------



  • 13.  RE: Untitled *.wor

    Posted 06-14-2021 13:48
    I stopped it and then it turned out that 80 million records had been imported. It was only the progress bar, which had stopped. It could probably have continued to 100 million then. The progress bar issue is probably related to going beyond 2 GB of the MIF file.


    ------------------------------
    Uffe Kousgaard
    ROUTEWARE
    Roskilde
    ------------------------------



  • 14.  RE: Untitled *.wor

    Posted 06-14-2021 20:57

    Hi Uffe,

     

    Great feedback, thank you.

     

    We have not been so lucky our end.

     

    Unable to process in MIP. Reverted to ArcGIS Pro for future tasks of this size I reckon.

     

    Cheers

     






  • 15.  RE: Untitled *.wor

    Posted 06-14-2021 04:22
    I recall having seen this a few times when MapInfo Pro runs into an error loading my workspace.

    I can't recall having seen it when the workspace is loaded without error.

    Do you get any errors or are you manually selecting tables to use when opening the workspace?

    ------------------------------
    Peter Horsbøll Møller
    Principal Presales Consultant | Distinguished Engineer
    Precisely | Trust in Data
    ------------------------------



  • 16.  RE: Untitled *.wor

    Posted 10-14-2021 12:31
    Heh Mike!  I'm having the same issue with the "Untitled.wor" when opening an existing workspace.  I had a client have the same issue.  Did you ever find a solution?  I've tried everything - and other than 'saving' the workspace right at the onset to the correct name, or another name, it doesn't seem to work.  Just curious.  A real pain!

    ------------------------------
    Giselle Schween
    Zone 14 GeoInfo Solutions
    Winnipeg MB
    ------------------------------



  • 17.  RE: Untitled *.wor

    Posted 10-14-2021 12:50
    I've seen this as well.
    -- Steve

    ------------------------------
    Steve Wallace
    Florida Farm Bureau Insurance
    ------------------------------



  • 18.  RE: Untitled *.wor

    Employee
    Posted 10-15-2021 09:10

    During testing for Autosave in v2100 we found this issue with AutoSave and its related to UAC settings in Windows 10 not MIPro as it stopped working for earlier MIPro versions too on same Windows machine.  This should be in the Release Notes provided with MIPro 2100.

    How to resolve issue if Workspace Auto-save preferences are no longer working
     

    Issue can be related to UAC (User Account Control) in Windows OS. 

    If the network mapped drives were created by an Admin without elevation, only that Admin (without elevation) can use the mapped drive and get the right drive type from the GetDriveType() API call that MIPro is using. There will be a problem if GetDriveType() returns DRIVE_NO_ROOT_DIR and not DRIVE_REMOTE for network mapped drives when the process is elevated in result from UAC in Windows.

    Workaround:
    Configure the EnableLinkedConnections DWORD (32-bit) value = 1
    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

    Relevant KB articles:
    https://groups.google.com/g/microsoft.public.win32.programmer.networks/c/5gcWAs8ZEeI
    http://support.microsoft.com/kb/937624 



    ------------------------------
    Bill Wemple
    Principal Software Engineer, Quality Management
    Precisely, Inc
    precisely.com
    ------------------------------



  • 19.  RE: Untitled *.wor

    Posted 11-04-2021 14:45
    Hello Mike,

    I am also having the exact same issue for a few months now. Meanwhile, I have switched from a personal laptop to a work laptop in a network-connected/ monitored environment. I have had that isssue with both laptops probably 90% of the time when opening a file. I am pretty new to MapInfo, so I am not sure what could be the cause and if this is a common problem. I do have a license for Discover 3 D that is "embedded" in MapInfo.... I am also noticing that when the project open up with the  *Untitled.wor my workspace arrangement is lost (i.e., the way I organize and place the different window tabs before saving).

    Regards,
    Simon

    ------------------------------
    Simon Gagne
    Knowledge Community Shared Account
    ------------------------------