MapInfo Pro

Expand all | Collapse all

Continue to Lose Customized Ribbon Band

  • 1.  Continue to Lose Customized Ribbon Band

    Posted 14 days ago
    This keeps happening (reverting back to default including commands and location) - could it somehow be related to auto-save?

    ------------------------------
    Rex Edwards
    CAMPBELL AVIATION GROUP
    Alexandria VA
    ------------------------------


  • 2.  RE: Continue to Lose Customized Ribbon Band

    Posted 10 days ago
    Hi Rex

    If MapInfo Pro is set up to automatically save your ribbon configuration on shut down, it will save it every time you shot down MapInfo Pro.
    Can you try to disable the automatic saving of the ribbon configuration?

    It should however also work with the automatic save option so you can also reach out to our tech support to see if they can figure out why it sometimes defaults back.

    ------------------------------
    Peter Horsbøll Møller
    Principal Presales Consultant | Distinguished Engineer
    Precisely | Trust in Data
    ------------------------------



  • 3.  RE: Continue to Lose Customized Ribbon Band

    Posted 4 days ago
    I have a similar issue, but with the Quick Access Toolbar.  It always reverts to the default.  I tried the fix suggested above, to no avail.

    ------------------------------
    Mark Duffett
    Department of State Growth
    Rosny Park TAS
    ------------------------------



  • 4.  RE: Continue to Lose Customized Ribbon Band

    Posted 3 days ago
    I have also been experiencing this, with both the Quick Access Toolbar and the Tool Window positions. A while back I created a copy of my "good" MapInfoPro.RibbonState.EN.xml and MapInfoPro.DockingState.xml, and then set up a batch file to overwrite the files in AppDat with my "good" copy, but now it seems that when I start MapInfo it deletes the MapInfoPro.RibbonState.EN.xml file completely until I exit, and then MapInfo recreates the default file.

    In the options, I have enabled Load on Startup and Save on Exit for both the Ribbon and the Tool Windows, and I have disabled Save Tool Windows with Workspace, and I have also tried disabling Save on Exit, and I have even made the files read-only, but I still keep losing my settings. Not every time I start MapInfo, but quite frequently.


    ------------------------------
    Sean Loos
    MAPPING SOLUTIONS
    ------------------------------