MapInfo Pro

Expand all | Collapse all

Default line style in Layout Designer

  • 1.  Default line style in Layout Designer

    Posted 06-28-2021 03:40

    Can the default line style in the layout designer be set to the default line style set in the backstage Options style.

    Clients have set the default line style for drawing onto the map window, but when they then move to the layout window its different. If it is different, is there a way we can set that via mapBasic?

    Cheers
    David



    ------------------------------
    David Wilson
    Buchanan Computing
    London, UK
    ------------------------------


  • 2.  RE: Default line style in Layout Designer

    Posted 06-28-2021 06:43
    Hi David

    For me, this seems to work. The default style in the Layout is similar to the default styles I have in the Spatial tab.
    I wonder if changing the preferences only is reflected in the Layout tab after restarting MapInfo Pro.

    I'm using MapInfo Pro v2019.3

    ------------------------------
    Peter Horsbøll Møller
    Principal Presales Consultant | Distinguished Engineer
    Precisely | Trust in Data
    ------------------------------



  • 3.  RE: Default line style in Layout Designer

    Posted 06-28-2021 07:29

    Hi Peter,
    Thanks for testing this.
    We're tending to use the OEM Runtime MI v2019.3 we've been issued with. So all the functionality is controlled by our code.
    The styles are set manually in the Options:


    Then we can plot using the spatial drawing tools (run menu command 1712)

    But when within the layout designer when using the draw polyline (run menu command 2959) its defaulted to a pecked blue line. The set style button (2936) has also changed the default style.
    If you then return to drawing within a map window, it has taken the layout line style, even if you do not click on the 'set style button'.
    I didn't think we were altering the default line style anywhere to this new style but I'll check, otherwise it may only be an issue with runtime.
    thanks
    David



    ------------------------------
    David Wilson
    Buchanan Computing
    London, UK
    ------------------------------



  • 4.  RE: Default line style in Layout Designer

    Posted 06-29-2021 03:29
    Hi David

    I just tried again with a freshly launched MapInfo Pro, and I'm still not able to reproduce this scenario of yours.
    As you can see below, the line is drawn with the same style on the map and on the layout which again is the same as my preference.

    I assume you have tried searching for the MapBasic statement "Set Style" in your code?
    Has the style also been changed for the map between opening the layout and using the Line tool in the Layout?

    ------------------------------
    Peter Horsbøll Møller
    Principal Presales Consultant | Distinguished Engineer
    Precisely | Trust in Data
    ------------------------------



  • 5.  RE: Default line style in Layout Designer

    Posted 06-29-2021 10:44
    Hi Peter,
    Thanks again for looking. I think you are correct we must be changing the style somewhere, although I've not managed to locate where just now. But I can reset it back to the original default styles once the layout has completed opening.
    Sorry to wast your time on it.
    David

    ------------------------------
    David Wilson
    Buchanan Computing
    London, UK
    ------------------------------