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Maplnfo Advanced Technical Workshop Introduction

The aim of this workshop is to familiarize Maplnfo users with MaplInfo Pro Advanced capabilities, let
them use supplied data and workspaces to explore Raster toolset. It is assumed that MaplInfo Pro 17.0.3
(or later) in installed and user has Advanced license.

Exercise 1 — Opening Raster Data

Data can be found at ...\Workshop\Ex-01

1) Navigate to the Workshop directory. Go to Home > Open Table and select Raster Image from
Files of Type.
2) Select the file called GB OST50 UK and click Open.
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7)

Use the pan and zoom tools to navigate around the map. Take note of the performance while
zooming and panning.

Navigate to Raster > Raster Info on the ribbon. Note the raster size, this information will give
you an idea of how many pixels are in the grid and give you rough ideas about performance for
certain queries and operations. The greater the size the longer some operations will take.

Try to turn On/Off Hill Shading.

Zoom in until you have a window width of about 5km (3 miles). You can check what window
with you are viewing by clicking in the status bar in the bottom left hand corner of the Maplinfo
interface and changing Cursor Location to Zoom (Window Width).

Once zoomed in to around 5km window width, navigate to the Raster tab in the Maplnfo ribbon
and select Raster Quality > Cubic Spline (Global). Note the significant increase in quality that
can be achieved using this option.

Right click the mouse and select View Entire Layer > All Layers. Leave the map open ready for
exercise 2.

Exercise 2 — Clipping Raster Data

Data can be found at ...\Workshop\Ex-02 (GB OST50 UK.mrr from Ex-01 is required if it has been closed

down).

[E
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Navigate to ...\Workshop\Ex-02 and ensure the file of type drop down is set to .tab.

Select UK Boundary and click Open.

Navigate to Raster > Raster Operations > Clip.

Ensure that the settings in Clip details pane on the right hand side of the Maplnfo interface are
set to Retain Inside and Region(Polygon). Polygon will be set to UK Boundary.

In Output File option, select the file explorer button and navigate to the Ex-03 folder. Save the
file as GB OST50 UK CLIP. Click Process. (This may take 1-2 minutes).

Close the original grid file GB OST50 UK and leave GB OST50 UK CLIP open. Leave this file open
for exercise 3.

Exercise 3 — Classify Raster Data

Data can be found at ...\Workshop\Ex-03

Ensure that GB OST50 UK CLIP is open in the map window.

Navigate to Statistics. Note the minimum and maximum height values in the details pane on
the right hand side. Based on the details decide upon some suitable height intervals to use for
the classification for example height intervals or 200m.

Navigate to Raster > Raster Operations > Classify.

Under Classify Options choose a Pseudocolor.lut style from the Derive Class Colors From drop
down.

Select the Intervals button, select Method and choose Interval Spacing.
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6) Set the Value to 200 and click OK.

Classify
A [nput
Input File GE OST30 UK_Clip v g
4 Classify Options
Output Raster Type Classified v
Class Interval Type Discrete <
Derive Class Colors from HE W r--udocoiori v
Interval list
Load... Save As. Intervals...
>=Value <Value Class Color
-200 0 -200ta 0
0 200 0 to 200
200 400 200 to 400
400 600 400 to 600
600 800 600 to 800
300 1000 800 to 1000
1000 1200 1000 to 1200
F 1200 1400 1200 to 1400
+H Insert Row El; Delete Row
4 Cutput
Cutput File GB OST50 UK_Clip_Classified ﬁ

* Output Settings

7) Navigate to the Output File Explorer and choose the ...\Ex-04. Name the file UK Classified
Elevation. Close all tables.

Note: Although this output may not be visually appealing, it does precisely visualize the highest
elevations in the UK. In many cases when raster data is used for analytics the aim will be to identify
particular areas or hotspots in a dataset. Classifications and color stretches are key to identifying
areas of interest.

Exercise 4 — Raster Data Statistics
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...\Workshop\Ex-04.

1) Open table UK Classified Elevation from ..\Workshop\Ex-04.

2) Navigate to the Raster tab and select Cell Value > Full. Now click in the map window. Notice
that the values being returned are a group or class value for example 200-400 meters above sea
level. This type of grid differs from a continuous grid where all vales are individual.

Raster statistics can be found very easily in MapInfo Advanced. In this case we need to find what

percentage of the UK land area is between 0 and 200m above sea level.

3) Navigate to the Raster tab and select Statistics. Note the values returned in the detail pane on
the right hand side of the MaplInfo Advanced user interface.

A Input
Input File
Select Fields, Bands
Statistics Mode
Statistics Quality

Calculate Statistics

Class |d Class

-200to O
0to 200

200 to 400
400 to 600
600 to 800
200 to 1000
1000 to 1200
1200 to 1400

Lo R B = O R R R

GB QST50 UK_Clip_Classified v | Eg
Field , Index -
Intermediate -
Full v
Count Percentage | Caolor
2149556 234 e
63552227  69.05 e
17925424 1947 e
6230757 677
1771158 192
368779 0.4
43675 0.05
2479 0 N

4) Click Save As and name the output csv file UK Elevation Statistics.csv and save to the Working
directory. This illustrates how quickly important statistics can be generated. More complex
guestions can be asked using the Calculator.

Exercise 5 — Assigning Values from a Raster to a Vector file

1) Open table GB OST50 UK CLIP from ...\Workshop\Ex-03 if it has been closed down.

2) Open table Highest Elevation Points UK from ...\Workshop\Ex-05.
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3) Maplnfo Raster’s Point Inspection tool will be used to assign the value from the open source
Ordnance Survey elevation grid to the points in the map.

4) Navigate to the Raster tab in the Maplinfo ribbon. Select Raster Tools > Point Inspection, set
the GB OST50 UK Clip file as the Input File. Set Highest Elevation Points UK as the Select Point
Layer. Set Output Mode as Edit input tab file and select output column Elevation.

5) Click Process.

6) Set an expression in the labels settings to show the name and elevation of the highest points in

o
[\

Y
Al ‘A
Y

affelPikeid72.7 m
3 5m

the UK.

Exercise 6 — Raster Queries

In order to define all of the lowland areas in the UK a query can be used. In this case all areas need to be
defined between 0 and 10 meters above mean sea level.

1) Open table GB OST50 UK CLIP from ..\Workshop\Ex-03 if it has been closed down.

2) Change style override for the raster layer to be

3) Navigate to the Raster tab. Go to Raster Tools > Calculator.

4) Select the Expressions drop down, there are number of predefined expressions created for use.

In this case the query needs to find all values from 0 to 20 meters. Consider if you want the
result to have values including 0 and 20 or including 0 and 20.
5) Example Expressions:
a. [Predefined Expression Used = Keep if >= or =<]

i. cond( >= 0, , null) and cond( <=20, , null)
b. [Keep Between Two Variables]
i. cond( >=0and <=20, , null)
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Calculator v x Calculator

&' gZ' feav € Load .&v gzv foaw B Load

Expressions Operators Functions Bl save Expressions Operators Functions Save
<9 Validate ¥ Clear <D E Validate "R Clear
cond( >=0, , null) and cond( <= 20, . null) cond(input_1 >=0 and Input_1<= 20, Input_1, null)

Inputs Variables Inputs Variables
Inputs  [§] Insert b New [ Remove Inputs  [§}] Insert [ New [ Remove

Alias Raster Alias Raster

Input_1 GB_OST50_UK_Clip '| fg||® Input_1 GB_OST50_UK_Clip -‘ | @

6) Define an Expression as above. Use can use Variables or use 0 and 20 values right in the

expression.
7) Click Compute. This process should take less than 30 seconds. The new grid will be opened into
the map window. Run the second variable option. Note the differences in results. One grid has

the original values and one has been classified.

Exercise 7 — Interpolation (population density)

Interpolation algorithms are used to create continuous surfaces that fill in the gaps between data points.
These are models of the real world, they don’t always represent the facts but try get as close as possible
to the geographic reality as is possible. A typical example would be creating a Digital Terrain Model
from a series of surveyed elevation points covering an area or LIDAR collected data. These algorithms
can also be used for analysis such as distance and density, for example a visual hotspot map can give a
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viewer the idea of the most populated areas of a county or the areas where the most incidents of crime
occur very quickly.

In this example territory of city Brno is divided into 100m by 100m squares and for each square
population is defined. Different interpolation methods will be used to create population density grid.

1) Open workspace BrnoPopulation.wor from ...\Workshop\Ex-07
2) Navigate to the Raster tab, click on Create Raster > Nearest Neighbor. Set the parameters as

below.
4 Input
Input File | Grid100m_popmerc_sample © ‘ =3
Select Columns |1 Selected © | ??
Group by | Select Column v ‘ %
Interpolate Along Edges

4 Interpalation Method

Select Method | Matural Meighbor v |

4 Method Options

Parameter Unit Distance ©

Distance Unit Meters ©

Maximum Search Distance 100

* More Options

4 Raster Geometry

Cell Size 50 ¥ Suggest|
Qutput Geometry O
* More Options
4 Cutput
Output File Grid100m_popmerc_sample PCPULATION ﬁ

w Output Settings

3) Select Population column in Select Columns

4) Save the Output File as Grid100m_popmerc_sample_POPULATION. Click Process. This process
will take a few seconds, it can be tested with different parameters, these will give slightly
different results and take more or less time.
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6) Resulting grid has a lot of blue cells that correspond to zero population value. It is possible to
ignore zero input values during gridding process. This can be done by clicking on Data
Conditioning Options button (next to Select Columns dropdown). Select Specify Invalid Data
option, click on Insert Row and leave zero as an invalid data value. Click Ok and click Process to
repeat gridding operation.

. ~ .o e e e
SRR . R
‘ . 5 ‘i5 g% “\ ‘-\.'- - AE‘ » ..‘51 ‘!;

* L 16 TN
7) « 7 4 TN \ Bl 3

8) Try ihcreasing Maximum Search Distance to 200 meters, changing Smoothing Method to
Gaussian, increase smoothing level. Try to turn on Hill Shading.

Exercise 8 — Interpolation (LIDAR data)

1) Go to Raster>Create Raster and select Triangulation method. This method usually works best
for LIDAR data. Click on Browse File button and change file type for LAS/LAZ files. Open
48122F2107.laz file from ..\Workshop\Ex-07 folder.

2) Select Z column for gridding, use Non-Earth meters coordinate system. In real situation you
need to provide correct projection for the LIDAR dataset. Use following parameters and get the

elevation grid that looks like this:

A Input

Input File |4B122F2107 - ‘ =]
Select Columns |1Saleded ~| kv
Group by ‘sam Column v‘ b
Interpolate Along Edges

4 Interpolation Method

Select Method ‘ Triangulation @

4 Method Options

Parameter Unit ‘Cel\s @

Maximum Triangle Size 100

 More Options

4 Raster Geometry

3)
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Cell Size 0.5 v ‘ Suggest
Qutput Geametry |
A Less Options
4 Projection Nen-Earth (meters)
Category ‘ Non-Earth v
Sub Categary ‘ Non-Earth (meters) .
4 Qutput
Output File 48122F2107_AllReturns R

 Output Settings




4)

Resulting grid is clearly an elevation grid, but it contains a lot of noise. Pro Advanced can be used
to filter the input LIDAR data by classification, returns and angle.

Click Data conditioning Options button and expand LAS Filtering options. Every time the laser
beam goes down, it gets multiple returns, they are numbered and you can select by data by
return, you can select by the intensity of the return. Depending on what the laser hit, different
intensity signal will come back to the measuring equipment. More useful option is to select by
classification and then by return or select by classification and then by intensity. When the client
gets the LIDAR data from the surveyor, the surveyor would have done some kind of classification
operation on the data and he would label all of the returns depending on what they are: so, if it
is a building or is the ground or perhaps a tree or it’s a surface of a road or is a deck of the
bridge or it’s a power line or other things. All of these are standard classifications and the
surveyor will provide all that information. So, we can select returns by classification. We know
that 2 corresponds to ground. Select ground and select last return. And there are other options
available for selecting a return. We can also do some restrictions based on the scanning angle.
The laser is moving from left to right and there is an angle from the vertical that is called scan
angle and if the angle is high, then you are looking right after the side of the measuring platform
and can get more distortion. So, let’s just restrict it to something smaller, let’s say ten degrees

on either side. This is how parameters would look:

4 Output Bands
Apply same data conditioning to :

4 Data conditioning aptions

Specify Invalid Data (]
Convert Null to backgreund O
Cap to Maximum O
Cap to Minimum (]
4 Coordinate conditioning options
Clip Region ‘ Mene
4 Las Filtering options
Selection Rule | Selact by classification then return
Classifications
J Value
2
+H Insert Row e Delete F
Selection by return rule Last return
Allow Z range (]
Allow intensity range ]
Allow scan angle range
From (Minimum) -10 To (Maximum) 10
Allow if synthetic O
Allow if withheld O

Click Ok, name it 48122F2107_Ground. Resulting grid really represents a terrain and can be used
for analysis. You can clearly see roads compared to the first iteration.

Close all and open another LIDAR dataset 16589_1_NCStatePlaneFt.las file and select Z column
for gridding. Click on Grouping Options button and select Classification column:
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Create Raster

Select Columns | Classification
Available ltems Selected ltems
6 - Building
17 - Bridge
2 - Ground

5 - High Vegetation

4 - Medium Vegetation

1 - Unclassified

3 - Low Vegetation

18 - High Poeint (High noise)
7 - Low Point (Low noise)

13 - Wire - Guard (Shield)

14 - Wire - Conductor (Phase)
10 - Rail

0 - Water

9)
10) Without any filtering and with the following parameters you will get the following grid:

5 NCAILNG_Buldings Map © * v CreateRaster

e oy
st ot 1%

CH.

v )
 Cutt St

11) frocesz| Close  Help.
12) If you select only Buildings classification (number 6), you will get a grid with just buildings

5 NC_nuildings Map & % o | s -

St Coues -

—
Graupy [omacowmn |
Intpolete Along Edges. v

4 prmjecien North aralina 3200 (1983, U3 Survey fee 92261
Catmgary U5 State Plane Coordinace Sstems (1583 for ~
Su Catezary Harth Carsina 1200 (1863, US Suneyfeetle ~

Cutgar i NG Buidings 3
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Exercise 9 - Heat Map

In this exercise we will create a Heat Map for distribution of employees of different industries across
Atlanta metropolitan area.
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1) Open workspace AtlantaPOl.wor from ..\Workshop\Ex-09 folder.

2) AtlantaPOI_PM table is derived from Pitney Bowes Points of Interest dataset and it corresponds
to locations of different employers across Atlanta metro area and has information about trade
division it belongs and it also has number of employees for each location.

3) Go to Create Raster and select Hotspot Density.

4) Select Column for gridding to be EMPLOYEE_HERE and specify Data Conditioning to ignore zero
values.

Create Raster Create Raster

4 Qutput Bands

4 Input
Input File | AtlantaPOl PM v | ﬁ Apply same data conditioning to :
Select Columns | 1 Selected " ‘ ?‘F 4 Data conditioning optiens
Group by | Select Column v | ?‘? Specify Invalid Data
Interpolate Along Edges Specify Invalid Values
4 Interpolation Method Value
Select Method | Hotspot Density w | 0
B Insert Row @ Delete Row

4 Method Options

Specify Invalid Ranges

Parameter Unit | Cells © |
 Less Options Erom To
Smoathi thod A o
maating mete | Leee | [ Insert Row Bl Delete Row:
Smoothing Level @
Convert Null to background [
Kernel |Quam'.: v |
Cap to Maximum O
Normalize by area O
Cap to Minimum O
Use input column as frequency
. 4 Coordinate conditioning options
Coincident Points Method | None
Clip Region Nene v
4 Search Options
Search Modes | Spherical v |
Major Axis Search 4
4 Raster Geometry
Cell Size | Automatic v Suggest|
Output Geometry ]
~ More Options
4 Cutput
Output File AtlantaPOl_PM_EMPLOYEE_HERE s
* Qutput Settings
Process| Close Help OK Cancel

5)
6) Make sure to select Quatric Kernel (works well for Heat maps) and check Use input column as

frequency. Click process and heat map will be created and will show distribution of overall
employes across the area.
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8) Next step is to use new Group by capability. Click on Group by button and select
TRADE_DIVISION column. Dialog will display all possible Trade division values, leave them as
they are and click OK button. Click Process button to recalculate the grid. In this case resulting
Raster will contain multiple fields and one can change which field is display by selecting
TRADE_DIVISION through Field button. Below are grids for Services (left) and wholesale (right).
You can see that services clearly has a big presence in downtown Atlanta and wholesale has
pockets of large concentration further away from the city centre.

@ epmTSS

9 ) @y G

Exercise 10 — Surface Tool and Calculator

This demo will utilize both raster and vector data to find areas of Albany neighbourhood that have high
slope (> 4 degrees) and identify streets that might need to be treated first in case of ice storm. Note that
4-degree slope corresponds to 7% grade. You will be using Albany elevation dataset and street network

vector dataset.

1) Open workspace Albany.wor from ...\Workshop\Ex-10 folder. This workspace have two tables:
first one (AlbanyElevation) is subset of Albany elevation data and second one (StreetsAlbany)

represent Albany streets.
2) First step is to calculate slope grid using Raster Surface tool. Select Surface button from Raster

Operations gallery. Use all default values to calculate the slope grid. Resulting grid should look
like this:
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3)
4) Next step is to find all areas that have a slope higher than 4 degree. We will use Classify tool to

create classify grid with only one class “High Slope” that would include all areas with a slope 4
degrees or high. You can use the same values for classification as shown below:

*Albany. WOR - Mapinio Pro

AL rasTER [
) Copy Raster % % @ M [I ! [ Pseudocoloriut  [E] Raster Quality « & E
B Delete Raster A Bl Advanced Color 8 Map Image Smootning «

GoRewme T S o Modtyinwge Cote Coniefter Fud Piewlo Conn- Cole iusmage  @FovorteTenglotes | opessene- p0M-

Open

v | Classity v x
4 input
Input File AlbanyElevation_Slope -y
4 Classify Options.
Output Raster Type Clessifed <
Class Interval Type Discrete M
Derive Class Colors from | MW pseudomoorne. %
Interval st
Glosd. B Savels Intervals...
[>avsve  cvake i Color
T 634522361755 High Siope N |
Updated 1 layer
Tables ¥
Kbanytlevation
Albanyflesation Slope
Albanyfievation Slope Classif
Streetsalbany & Inert R B Delete Row
Windows ¥ 7
Maps (1) ¥ 4 Output
vﬂ. Mm 'Alh-n/..‘nluny(lrvmn Map Output File 3 ;»:,:y:n_sxopmmm i
[ MapBasic
1 Message
[ Ruler
[ into
[ Theme Leqend
Tasks. - s x
Q
% Classify : o Comoetes
3 Surface o Competed rocess]| Coen | Hilp
= = B Surfsce Analysis  E3 Classity
Thm & 73 N
i ® st 0 Ny # it Y Wor @ Stypefor MME M. @ An apinto P Maplof @ Untited 3 MapinfoP... |2 *AlbanyW. =

6) Next step is to convert classified Raster into polygons. This could be done by running Polygonise
tool on AlbanyElevation_Slope_Classified raster:
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8)

9)

D Copy Raster @ IE % %
1 Delete Rastes i

El B M K g.rscor muomimmce oo

OPen iy perame Fer S Cell M Fidd Clasi. Inde Cler
Fe Prop Displ,

e v
X 2 8 Search
Maps ¥
4 M StreetsAlbany....AlbanyElevation Map

v Cosmetic Layer

W) < Streetsalbany &

7] AlbsnyElevation_Slope_Cia 2 &

o

Paiygorie - x

4 Input

Input File AlbanyElevation_Slope Classifie ~ | i3
P

Metd [somevonecan ]

Match Coloes to Input 4}

Display Ragion Border Linw [
4 Output

Output File AtbanyElevation Slope Classfied 7|
= Ot settngs

. Cla2
AlanyElevation_Siope_ Classif

Windows ¥
Maps (1) ¥
4] Streetsalbany... Albanylevation Map
Tools (9) ¥
[ MapBasic
(] Message
(] Ruler

O info

Tasks ve x

5 Polygonise o Coroees
Trec
% Polygonise o Competed

Process, Close  Help
7 secs

B Surdace Analysis £ Classity " Polygonise

default

Next step is to run a SQL query to select all roa
Select dialog and select the following query:

S0L Select x

Select Columns: = I Tables e
Columns
Operators
Aggregates

from Tables: | StreetsAlbany, AlbanyElevation_Slope_Cla_2

| IFunct'lons :l

where Condition: | Streetsalbany.Obj Intersects
AlbanyElevation_Slope_Cla_2.0bj

Group by Columns: | |

QOrder by Columns: |

into Table Named: | HighSlopestreets | Load Template

Browse Results [ Find Results In Current Map Window
Add Results To Current Map Window

[ o ]| cancel | | clear || venfy || el

10) HighSlopeStreets table will be added to the map. Uncheck visibility of polygon map and this is

how result should look:
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